Microworlds Pro

Προγραμματισμός με Logo

Τι πρέπει να γνωρίζεις;

Θα χρησιμοποιήσουμε τη γλώσσα προγραμματισμού Logo και θα προγραμματίσουμε χελώνες. Η χελώνα που «ζει» στην οθόνη του υπολογιστή ανταποκρίνεται σε εντολές της Logo. Η Logo και ειδικότερα η γεωμετρία χελώνας είναι ένα ιδιαίτερα ενδιαφέρον περιβάλλον για την εισαγωγή στον προγραμματισμό και την εκμάθηση βασικών ιδεών στα μαθηματικά.

Η χελώνα εμφανίζεται στην οθόνη ως εικονική αναπαράσταση μιας χελώνας έτσι ώστε να φαίνονται καθαρά η θέση και η κατεύθυνσή της (δηλαδή, προς τα πού είναι στραμμένη). Αυτά είναι τα βασικά στοιχεία της κατάστασης μιας χελώνας. Οι πιο σημαντικές εντολές Logo που ελέγχουν τη χελώνα είναι αυτές που αλλάζουν την κατάστασή της. Για παράδειγμα, οι εντολές μπροστά (ή, για συντομία, μπ) και πίσωπι) τη μετακινούν, ενώ οι εντολές αριστεράαρ) και δεξιάδε) την περιστρέφουν. Η χελώνα επίσης μεταφέρει ένα στυλό. Αν τοποθετήσετε το στυλό κάτω (ΣτυλόΚάτω ή, για συντομία, ΣτΚ), η χελώνα αφήνει ίχνη στο πέρασμά της.

Δοκιμάστε να πληκτρολογήσετε στο Κέντρο Εντολών τις παρακάτω οδηγίες:

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
ΣτυλόΚάτω μπροστά 100 δεξιά 45μπροστά 100
Η εντολή μπροστά 100 μετακινεί τη χελώνα 100 βήματα μπροστά.
Η εντολή δεξιά 45 περιστρέφει τη χελώνα κατά 45 μοίρες προς τα δεξιά, χωρίς να αλλάζει η θέση της.

Ας δοκιμάσουμε να δώσουμε εντολές στη χελώνα για να σχεδιάσει ένα τετράγωνο.

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
μπροστά 100 δεξιά 90 μπροστά 100 δεξιά 90 μπροστά 100 δεξιά 90 μπροστά 100 δεξιά 90
Η εντολή μπροστά 100 μετακινεί τη χελώνα 100 βήματα μπροστά.
Η εντολή δεξιά 90 περιστρέφει τη χελώνα κατά 90 μοίρες προς τα δεξιά, χωρίς να αλλάζει η θέση της.

 

Το ίδιο αποτέλεσμα μπορούμε να έχουμε χρησιμοποιώντας την εντολή της επανάληψης.
Η εντολή επανάλαβε δέχεται ως είσοδο μια λίστα οδηγιών.
[Η λίστα οδηγιών είναι ένα σύνολο εντολών που θα εκτελεστούν από τη Logo.]

Η ακόλουθη οδηγία δίνει εντολή στη χελώνα να σχεδιάσει ένα τετράγωνο, με επανάληψη των εντολών μπροστά 100 και δεξιά 90 τέσσερις φορές.

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
επανάλαβε 4 [μπροστά 100 δεξιά 90]
Αν δώσετε διαφορετικές τιμές στην εντολή μπροστά, σχηματίζονται τετράγωνα διαφορετικών μεγεθών.

Μπορείτε τώρα να σχεδιάσετε ένα τρίγωνο με μια απλή οδηγία:

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
επανάλαβε 3 [μπροστά 100 δεξιά 120]

 

Στη γεωμετρία χελώνας η γωνία κατά την οποία περιστρέφεται η χελώνα είναι η εξωτερική γωνία. Παρατηρήστε πως, είτε η χελώνα σχεδιάζει τρίγωνο είτε τετράγωνο, ο συνολικός αριθμός των μοιρών περιστροφής είναι σταθερός. Αν σχεδιάσετε με τη χελώνα ένα τετράγωνο, θα παρατηρήσετε πως η χελώνα κάνει μια ολική περιστροφή 360 μοιρών.
[Ολική περιστροφή 360 μοιρών σημαίνει να περιστραφεί η χελώνα μέχρι να γυρίσει στην αρχική της θέση και κατεύθυνση γιατί ένας κύκλος έχει 360 μοίρες.]

Στην πραγματικότητα, η χελώνα περιστρέφεται κατά 360 μοίρες προκειμένου να σχεδιάσει ένα απλό πολύγωνο:

  • 4 χ 90 = 360 (τετράγωνο)
  • 3 χ 120 = 360 (τρίγωνο)

Έτσι καταλήγουμε στο θεώρημα που είναι γνωστό με το όνομα «Θεώρημα ολοκληρωμένης διαδρομής της χελώνας».

Θεώρημα ολοκληρωμένης διαδρομής της χελώνας

Η χελώνα περιστρέφεται κατά 360 μοίρες για να ολοκληρώσει τη διαδρομή της γύρω από ένα απλό κλειστό σχήμα και να επιστρέψει στην αρχική της θέση και κατεύθυνση.

Μπορείτε να χρησιμοποιήσετε αυτό το θεώρημα, αλλάζοντας τις τιμές στις οδηγίες Logo, προκειμένου να σχεδιάσετε και άλλα πολύγωνα:

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
επανάλαβε 5 [μπροστά 100 δεξιά 72]
δεξιά 72, γιατί 5 Χ 72ο = 360ο Πεντάγωνο

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
επανάλαβε 6 [μπροστά 100 δεξιά 60]
δεξιά 60, γιατί 6 Χ 60ο = 360ο Εξάγωνο

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
επανάλαβε 8 [μπροστά 100 δεξιά 45]
δεξιά 45, γιατί 8 Χ 45ο = 360ο Οκτάγωνο

Αν πειραματιστείτε αρκετά, θα διαπιστώσετε πως το θεώρημα δεν ισχύει για όλες τις περιπτώσεις:

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
επανάλαβε 5 [μπροστά 100 δεξιά 144]

Η οδηγία αυτή λέει στη χελώνα να σχεδιάσει ένα αστέρι. Αυτή τη φορά η χελώνα κάνει δύο ολικές περιστροφές, δύο φορές κατά 360 μοίρες, δηλαδή κατά 720 μοίρες.

Έτσι καταλήγουμε στο «Θεώρημα ολοκληρωμένης διαδρομής της χελώνας» Νο 2

 

Θεώρημα ολοκληρωμένης διαδρομής της χελώνας Νο 2

Η χελώνα περιστρέφεται κατά 360 μοίρες ή κατά ένα πολλαπλάσιο των 360 μοιρών για να ολοκληρώσει τη διαδρομή της γύρω από ένα απλό κλειστό σχήμα και να επιστρέψει στην αρχική της θέση και κατεύθυνση.

Όπως θα έχετε καταλάβει, η μετακίνηση της χελώνας είναι ανεξάρτητη από την περιστροφή της. Η ανεξαρτησία μετακίνησης και περιστροφής στη γεωμετρία χελώνας είναι ένα πολύ δυναμικό στοιχείο.

Για παράδειγμα, χάρη σε αυτό το χαρακτηριστικό μπορείτε εύκολα να σχεδιάσετε το ίδιο σχήμα με διαφορετικό προσανατολισμό:

ΕΝΤΟΛΕΣ ΑΠΟΤΕΛΕΣΜΑ
επανάλαβε 5 [επανάλαβε 4 [μπ 100 δε 90] δε 72]
Δηλαδή: φτιάξε 1 τετράγωνο (επανάλαβε 4 [μπ 100 δε 90]), στρίψε κατά 72ο δεξιά (δε 72) μόλις το σχηματίσεις και επανάλαβε τη διαδικασία αυτή 5 φορές (επανάλαβε 5)

 

Τι είναι διαδικασία στη Logo;

Η διαδικασία είναι μια λίστα οδηγιών με όνομα.

Αφού δημιουργήσετε μια διαδικασία, πληκτρολογείτε απλώς το όνομά της και ξεκινά η εκτέλεση όλων των οδηγιών που αυτή περιέχει.

Μια διαδικασία αποτελείται από τρία μέρη:

για τετράγωνοεπανάλαβε 4 [μπ 100 δε 90]τέλος τη γραμμή τίτλουτις οδηγίεςτη γραμμή τέλους

 

Στη γραμμή τίτλου οι διαδικασίες ξεκινούν με το για και ακολουθεί το όνομα της διαδικασίας. Το όνομα της διαδικασίας δεν πρέπει να περιέχει κενά διαστήματα. Οι διαδικασίες μετά τις οδηγίες τελειώνουν πάντα με τη λέξη τέλος σε ξεχωριστή γραμμή.

Πώς θα ορίσω μια διαδικασία;

1. Πώς θα ορίσω μια απλή διαδικασία (διαδικασία χωρίς μεταβλητές)

  • Στην Καρτέλα Διαδικασίες γράφεις για -κενό- (όνομα διαδικασίας).
  • Αλλάζεις γραμμή( πατώντας Enter).
  • Γράφεις τις εντολές που θέλεις να έχει η διαδικασία (κατά προτίμηση μία εντολή σε κάθε σειρά).
  • Γράφεις την εντολή τέλος.
Παραδείγματα απλών διαδικασιών
για τετράγωνο επανάλαβε 4 [μπ 100 δε 90]τέλος για ορθογώνιοεπανάλαβε 2 [μπ 100 δε 90 μπ 50 δε 90]τέλος

Στη γραμμή τίτλου οι διαδικασίες ξεκινούν με το για και ακολουθεί το όνομα της διαδικασίας. Το όνομα της διαδικασίας δεν πρέπει να περιέχει κενά διαστήματα. Οι διαδικασίες μετά τις οδηγίες τελειώνουν πάντα με τη λέξη τέλος σε ξεχωριστή γραμμή.

2. Πώς θα ορίσω μια παραμετρική διαδικασία (διαδικασία με μεταβλητές)

  • Στην Καρτέλα Διαδικασίες γράφεις για -κενό- (όνομα διαδικασίας) -κενό- :(σύμβολο μεταβλητής).
    [Μπορείς να επαναλάβεις τη διαδοχή [-κενό- :(σύμβολο μεταβλητής)] τόσες φορές όσες και οι μεταβλητές που θέλεις να έχει η διαδικασία].
  • Αλλάζεις γραμμή( πατώντας Enter).
  • Γράφεις τις εντολές που θέλεις να έχει η διαδικασία (κατά προτίμηση μία εντολή σε κάθε σειρά).
  • Γράφεις την εντολή τέλος.
Παραδείγματα παραμετρικών διαδικασιών
Παράδειγμα παραμετρικής διαδικασίας με μια μεταβλητή
για τετράγωνο :χ επανάλαβε 4 [μπ :χ δε 90]τέλοςτετράγωνο 50
Παράδειγμα παραμετρικής διαδικασίας με δύο μεταβλητές
για ορθογώνιο :χ :ψ επανάλαβε 2 [μπ :χ δε 90 μπ :ψ δε 90]τέλοςορθογώνιο 50 80